
 

QuickLaunch Account Preparation 
 

Quicklaunch has created this preparation checklist in order to provide the best possible experience to your team in our 
upcoming deployment of QuickLaunch. If you have any questions when going through this checklist, please do not hesitate 
to let us know. 
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Engagement Contacts 
Provide a list the contacts for the engagement. 

Name Role Email Address Phone Office Location 
     

     

 
 
  



 

Checklist 

Account Requirements 
 

QuickLaunch is a Windows application that requires an account for the Windows operating system (OS), Exchange 

calendaring and Skype for Business/Lync unified communication services. Although recommended to use a single 

account to authenticate into these three services, QuickLaunch’s modular design allows for a variation of accounts to 

access these services. The following will break down each service’s account requirements. 

 

Document Style Conventions 
 

Throughout this document, various snippets of computer code may be included to provide explanation. Due to the 

length of some of these commands, and the limitations of this printed medium, longer lines will be word-wrapped. 

Where a new-line is required, a dotted separating line will be used to separate multiple lines at the point of pressing 

the “Enter” key. 

 

The following indicates a series of commands, with word-wrapped text that should be entered as two complete lines: 

$services = Get-WMIObject Win32_Service | Where-Object {$_.Description -imatch "Lync" -and 

$_.StartMode -eq "Auto"} 

Foreach ($service in $services){sc.exe failure $service.name reset= 86400 actions= 

restart/5000} 

 

The following shows one very long command, typed without pressing enter until the final “e:\sources\sxs” row is 

typed: 
Add-WindowsFeature RSAT-ADDS, NET-Framework-45-Core, Windows-Identity-Foundation, NET-

Framework-Core, Web-Server, Web-Static-Content, Web-Default-Doc, Web-Http-Errors, Web-Asp-

Net, Web-Net-Ext, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Http-Logging, Web-Log-Libraries, 

Web-Request-Monitor, Web-Http-Tracing, Web-Basic-Auth, Web-Windows-Auth, Web-Client-Auth, 

Web-Filtering, Web-Stat-Compression, Web-Dyn-Compression, NET-WCF-HTTP-Activation45, Web-

Asp-Net45, Web-Net-Ext45, Web-Mgmt-Tools, Web-Scripting-Tools, Web-Mgmt-Console, Web-Mgmt-

Compat, Desktop-Experience, Telnet-Client, Server-Media-Foundation, BITS -source 

e:\sources\sxs 

 

Please pay close attention to the lack of a separator line between multiple rows on the latter example, compared to 

the former. 

 

  



 

Windows 
 

QuickLaunch is a Windows 32bit application built using ClickOnce Technology that allows a user without 

administrative right to install. This application can run on either 32bit or 64bit versions of Windows 7, 8, 8.1, 10. The 

system running QuickLaunch should have access to the internet for application licensing and updating. The user 

account used to login to the OS can be either a local or domain account and the system can be configured as a 

Shared or Resource computer.  

 

Shared Computer (Option 1): A standard Windows computer that allows individual users to use their own credentials 

to authenticate to the system. 

Configure:  

 Computer is either joined to a domain or workgroup (Windows Home editions cannot be domain joined) 

 Each user has an account that can sign into the system 

 QuickLaunch is installed per user and application settings are per computer 

Notes: 

 To auto install/run QuickLaunch for every user on a computer:  

o Install QuickLaunch for a single user 

o Configure the QuickLaunch application settings 

 The “App starts automatically” setting isn’t required 

o Copy the QuickLaunch desktop shortcut (ClickOnce Application Reference) and place it in the 

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\ folder 

 In some scenarios with Office 365 it might be required to disable Internet Explorer’s Single Sign On: 

o In Internet Explorer, go to the Tools -> Internet Options -> Advanced tab and uncheck the 

“Enable Integrated Windows Authentication” check-box 

o Next, switch to the security tab and click Local Intranet -> Custom Level and select “Prompt for 

user name and password” (under User Authentication, Logon)  

 

Resource/Room Computer (Option 2): A Windows computer that is constantly signed in with the same user. This 

system can be configured for automatic logon or the password is shared/known to all the users using the system.  

Configure: 

 Computer is either joined to a domain or workgroup (Windows Home editions cannot be domain joined) 

 Resource/Room’s Windows account credentials are known to all users or Windows is configured for 

automatic logon 

 QuickLaunch is installed and configured under the Resource/Room account 

Notes: 

 Windows automatic Login:  

Important this feature is provided as a convenience. However, this feature may be a security risk. If 

you set a computer for automatic logon, anyone who can physically obtain access to the computer 

can gain access to all the computer's contents, including any networks it is connected to. 

Additionally, when automatic logon is turned on, the password is stored in the registry in plain text. 

Appropriate steps should be taken to lock down the computer and network access the 

Resource/Room account has rights to. 

o Run Regedit.exe as an administrator 

o Navigate to: “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 

NT\CurrentVersion\Winlogon\” 



 

o Set or create the following (replace <value> with the appropriate value): 

 AutoAdminLogon (String): 1 

 DefaultDomainName (String): <Domain Name> 

 DefaultUserName (String): <User Name> 

 DefaultPassword (String): <Password> 

 ForceAutoLogon (DWORD): 1 

 ForceUnlockLogon (DWORD): 1 

o If exists, delete the AutoLogonCount (DWORD) 

o Restart and verify automatic login was successful 

o To bypass the automatic login process and to log on as a different user, press and hold the Shift 

key after you log off or after Windows restarts. If that doesn’t work modify the values for 

AutoAdminLogon/ForceAutoLogon/ForceUnlockLogon to 0. 

 QuickLaunch has built-in Lockdown/Kiosk mode functionality that can be optionally enabled which 

removes the default Windows shell and replaces it with the QuickLaunch application. 

Document the following: 

 OS Version/Edition and System Type (Control Panel\All Control Panel Items\System) 

 Type of computer (Shared | Resource) 

 User, Password, Domain/Workgroup 

 Lockdown/Kiosk mode required (Yes | No) 

Testing: 

 Sign into computer with documented details 

  



 

Exchange 
QuickLaunch leverages Exchange Web Services (EWS) to provide calendaring access within the application. 

Supported EWS versions: Exchange 2007/2010/2013/2016/Online. The account used to login to EWS services can be 

either a User or Resources mailbox that has EWS enabled, a password set and is logon enabled. 

 

User Mailbox (Option 1): A standard user that has been enabled for Exchange. 

Configure:  

 Exchange 2007/2010 

o Launch Exchange Management Console 

 Recipient Configuration 

 New Mailbox Wizard 

 User Mailbox 

 New or Existing User 

 User Information (New User) 

 Mailbox Settings 

 Archive Settings (2010+) 

 New Mailbox 

 Completion 

 Exchange 2013/2016/Online 

o Launch Exchange Admin Center (2013/2016/Online): 

 Recipients 

 Mailboxes 

 New User Mailbox 

 Existing/New 

 

Resource (Room) Mailbox (Option 2): A bookable resource that usually represents a physical location or device 

configured in Exchange. 

Configure: 

 Exchange 2010 

o Launch Exchange Management Console 

 Recipient Configuration 

 New Mailbox Wizard 

 Room Mailbox 

 New or Existing User 

 User Information (New User) 

 Mailbox Settings 

 New Mailbox 

 Completion 

o Launch Active Directory Users and Computers 

 Find Resource (room) object 

 Set Password 

 Enable Account 

o Launch Exchange Management Shell (replace Resource Mailbox in the following commands with 

the correct identity for the object) 

 Configure Calendar Processing (recommended options for best user experience) 



 

Set-CalendarProcessing -Identity “Resource Mailbox” -AutomateProcessing AutoAccept -

AddOrganizerToSubject $false –DeleteSubject $false -RemovePrivateProperty $false -

DeleteAttachments $false -DeleteComments $false –ProcessExternalMeetingMessages $true 

 Set MailTip 

Set-Mailbox -Identity “Resource Mailbox” -MailTip "This room is equipped with QuickLaunch, 

please make it a Skype Meeting to take advantage of the enhanced meeting experience” 

  

 Exchange 2013/2016/Online 

o Launch Exchange Admin Center 

 Recipients 

 Resources 

 New Resource Mailbox 

 New 

o Launch Exchange Management Shell (replace Resource Mailbox in the following commands with 

the correct identity for the object) 

 Set password and enable resource account 

$pass = Read-Host "Enter password" -AsSecureString 

Set-Mailbox -identity “Resource Mailbox” -RoomMailboxPassword $Pass -

EnableRoomMailboxAccount $true 

 Configure Calendar Processing (recommended options for best user experience) 

Set-CalendarProcessing -Identity “Resource Mailbox” -AutomateProcessing AutoAccept -

AddOrganizerToSubject $false –DeleteSubject $false -RemovePrivateProperty $false -

DeleteAttachments $false -DeleteComments $false –ProcessExternalMeetingMessages $true 

 Set MailTip 

Set-Mailbox -Identity “Resource Mailbox” -MailTip "This room is equipped with QuickLaunch, 

please make it a Skype Meeting to take advantage of the enhanced meeting experience” 

Notes: 

 If using Exchange Online, use the following to start a tenant remote PowerShell to run the Set-

Mailbox and Set-CalendarProcessing commands 

$EOCredential = Get-Credential 

$EOSession = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri 

https://outlook.office365.com/powershell-liveid/ -Credential $EOCredential -Authentication 

Basic -AllowRedirection 

Import-PSSession $EOSession 

o Disconnect from Exchange Online 

Remove-PSSession $EOSession 

 

Document the following: 

 Exchange server version hosting the mailbox (2007 | 2010 | 2013 | 2016 | Online) 

 Type of Mailbox (User | Resource) 

 Mailbox Name, Password, Domain, Email Address 

 EWS URL (typically https://mail.domain.com/EWS/Exchange.asmx) 

 Webmail/EWS authentication format (ADDomain\UserID | UserID | Email Address) 

Testing: 

 Open Webmail and authenticate with documented details 

https://mail.domain.com/EWS/Exchange.asmx


 

 Open Remote Connectivity Analyzer (https://testconnectivity.microsoft.com/) and run Microsoft Exchange 

Web Services Connectivity Tests with documented details on either the Exchange Server or Office 365 tabs 

depending on the server version hosting the specific mailbox. 

 Using EWSEditor (https://ewseditor.codeplex.com/) to testing EWS connectivity with documented details. 

o Install EWSEditor 

o Run EWSEditor.exe 

 File -> New Exchange Service… 

 Enter Service URL (EWS URL) 

 Select EWS Schema Version 

 Check “Use the following credentials instead of the default Windows credentials” 

 Enter User Name/Password and Domain if required 

 Click Ok (any connection errors or warnings will be returned in a popup). 

  

https://testconnectivity.microsoft.com/
https://ewseditor.codeplex.com/


 

Skype for Business/Lync 
QuickLaunch requires the Windows desktop Skype for Business 20015/2016 or Lync 2013 client. Supported Server 

versions: Skype for Business/Lync 2010/2013/2015/Online. The account used to login to the Skype for Business/Lync 

client can be either a User or Meeting Room account that has a password set and is logon enabled. 

 

User Account (Option 1): A standard user that has been enabled for Skype for Business/Lync. 

Configure:  

 Skype for Business/Lync Server 2010/2013/2015/Online 

o Launch Skype for Business/Lync Server Control Panel (CSCP) 

 Users 

 Enable users 

 Add.. 

o Search for User account to Enable 

 Assign user to a pool 

 Generate user’s SIP URI 

 Configure Telephony settings 

 Assign Policies 

 

Meeting Room Account (Option 2): A conferencing device that usually represents a physical device used to access 

conferencing and collaboration services. The following adds Skype for Business/Lync services to an Exchange 

Resource (Room) mailbox. 

Configure: 

 Skype for Business/Lync Server 2013/2015/Online 

o Launch Skype for Business/Lync Server Management Shell  

 Enable an Exchange Room to be a Skype for Business/Lync Meeting Room 

 Replace Test Room1 with Meeting Room’s Identity 

 Replace testroom1@domain.com with Resource Mailbox email address 

 Replace FEPool.domain.com with the room’s Front End pool 

Enable-CsMeetingRoom -Identity "Test Room1" -SipAddress "sip:testroom1@domain.com" -

RegistrarPool FEPool.domain.com 

 (Optional) Enable Meeting Room account for Enterprise Voice 

 Replace Test Room1 with Meeting Room’s Identity 

 Replace +14031234567 with Meeting Room’s E.164 phone number 

Set-CsMeetingRoom "Test Room1" -LineURI "tel:+14031234567" -EnterpriseVoiceEnabled $true 

 (Optional) Grant the appropriate policies to the Meeting Room 

 Replace Test Room1 with Meeting Room’s Identity 

 Replace Policy with correct policy names. 

Get-CsMeetingRoom -Identity "Test Room1" | Grant-CsConferencingPolicy -PolicyName "Policy" 

Get-CsMeetingRoom -Identity "Test Room1" | Grant-CsVoicePolicy -PolicyName "Policy" 

Get-CsMeetingRoom -Identity "Test Room1" | Grant-CsDialPlan -PolicyName "Policy" 

Get-CsMeetingRoom -Identity "Test Room1" | Grant-CsClientPolicy -PolicyName "Policy" 

 (Optional) Update all Conferencing Policies to prompt to make a Skype for 

Business/Lync Meeting when booking Meeting Rooms in Outlook 

Get-CsConferencingPolicy | Set-CsConferencingPolicy -

EnableOnlineMeetingPromptForLyncResources $true 



 

 (Optional) High Performance settings, available if there is sufficient network capacity 

 Replace Policy with correct policy names. 

Set-CsClientPolicy -Identity "Policy" -EnableHighPerformanceConferencingAppSharing $True -

EnableHighPerformanceP2PAppSharing $True 

Notes: 

 If using Skype for Business/Lync Online, use the following to start a tenant remote PowerShell to run the 

Enable-CsMeetingRoom and Grant policy commands 

o Download and Install the Skype for Business Online Connector module: 

https://technet.microsoft.com/en-us/library/dn362829.aspx 

Import-Module LyncOnlineConnector 

$LOCredential = Get-Credential 

$LOSession = New-CsOnlineSession -Credential $LOCredential 

Import-PSSession $LOSession -AllowClobber 

o Get Registrar Pool (required for Enable-CsMeetingRoom, replace user@doamin.com with an 

existing Skype for Business/Lync Online user) 

Get-CsOnlineUser -identity user@domain.com | FT identity, registrarpool 

o Disconnect from Skype for Business/Lync Online 

Remove-PSSession $LOSession 

 

Document the following: 

 Skype for Business/Lync server and client versions hosting the account (2010 | 2013 | 2015 | 2016 | Online) 

 Type of Account (User | Meeting Room) 

 User Name and format (ADDomain\UserID | Sip Address) 

 SIP Address, Password 

Testing: 

 Open Skype for Business/Lync Windows desktop client and authenticate with documented details 

 

  

https://technet.microsoft.com/en-us/library/dn362829.aspx


 

Additional Notes 
 

Group Policies:  When you join a QuickLaunch PC to the domain, it is recommended that you create a separate 

Organizational Unit (OU), so that you can provide Group Policy Object (GPO) exclusions to the OU where all the 

QuickLaunch machine objects reside. Even if you create a separate OU and block inheritance, there are some policies 

which could cause issues at a higher level. A Group Policy with No Override setting beats an OU with a Block Policy 

Inheritance setting. For more information, see the article “No Override as Compared to Block Policy Inheritance” in 

the Group Policy documentation at http://technet.microsoft.com/en-us/library/cc978255.aspx. 

 

GPO policies that could impact QuickLaunch are: 

 Timeout of logon sessions (auto lockout) 

 Power management related policies 

 Requiring additional authentication steps 

 Denying access to local drives 

 Prompting users for slow network connections 

 Start a certain program at logon 

 

Password Expiry: When deploying QuickLaunch be mindful of the password expiry policy applying to the accounts 

QuickLaunch is configured to use for Windows, Exchange and Skype for Business/Lync. User experience can be 

impacted if accounts expire or configured program passwords aren’t updated after a password change. 

 

QuickLaunch: 

 Testing Accounts – QuickLaunch has a built-in utility to test the Exchange Web Services account information 

located in QuickLaunch Settings -> Security -> General ->Verify 

 

 Change User – QuickLaunch has the ability to temporarily change the Exchange Web Services and Skype for 

Business/Lync accounts on the fly from the Dashboard. This allows a user to view their Calendar and Contacts 

from within a Meeting Room. This feature can be disabled within QuickLaunch Settings -> Security -> 

General -> Allow Change User? 

http://technet.microsoft.com/en-us/library/cc978255.aspx

