Symptoms:
With Quicklaunch connected to Google Calendar the calendar does not display or no calendar items are not displayed
Diagnosis:
In the event log the message: GoogleApiException Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT). You may monitor your quota usage and adjust limits in the API Console
Solution:
You will need to create a Google API client ID and secret and then enter them into Quicklaunch.
Create a Google API Client Id and Secret
1. In a web browser, sign into your Google account
2. Go to URL: https://console.cloud.google.com/
3. Enable Google Calendar: APIs & Services> Library> Google Calendar>Enable
4. Create a new project associated with your company and create
5. In APIs & Services > Credentials > Create Credentials > Select OAuth client ID
6. after you have selected OAuth client> Create Oauth client> Select Other> Name
Enter Google Client ID and Secret into Quicklaunch:
Once you have the Google Client ID and Client Secret, enter them into Quicklaunch:
- Go to Quicklaunch -> Settings -> Account
- On the Right Hand Side, select Change Account Type
- Click Next until you reach the page "Google Accounts"
- Click Sign out of Google
- In Windows File Explorer delete the folder: C:\Users\{userid}\AppData\Roaming\Quicklaunch.Google.Auth.Store
- Go back to Quicklaunch
- Check the box Use Google API Credentials
- Enter your Client ID and Client Secret from above
- Click Sign In with Google
- Select your Google calendar
- Click Finish
NOTE: